[Mailman-Users] How to properly nest a response from Gmail

BA lanfest ba.lan.fest.08 at gmail.com
Sun Dec 23 21:24:47 CET 2012

Actually, scratch that last part about correct threading in the absence of
"In-Reply-To" header.  I just re-checked, and that was actually only
threaded one level down, which was coincidentally the correct level, but is
also where replies end up going even if they should be deeper, when missing
the header.  Sorry for the confusion, I think I have it all sorted out now!

On Sun, Dec 23, 2012 at 12:19 PM, BA lanfest <ba.lan.fest.08 at gmail.com>wrote:

> MUCH thanks for the reply Mark.  I've been looking for help everywhere and
> yours is the first response I've received.  I was referring to the archived
> view threading on the web.
> Another possibility is a reply get's sent to you and then resent to the
>> list as a separate message. If you reply to the copy sent to you, your
>> reply is not a reply to the message in the list archive so it isn't
>> threaded as such.
> I am pretty sure this is what happened.  When I replied to the first
> message (which did not thread correctly), my subscription mode was digest
> only so I was not getting individual messages, but I did get a message in
> my inbox from the member I wanted to respond to, because he mailed me a
> separate copy.  I replied to that, and I'm guessing like you said it had a
> different Message-ID.
> Later I changed my subscription to non-digest mode, and then when I
> replied to one of those that I received (i.e. a message actually sent to
> the list and not just me), it did thread properly.
> However, the absolute weirdest thing is this.  Yesterday, I signed up for
> a few other lists to run some tests.  One thing I tried was responding to
> an archive message straight from the web using the <a href="mailto:someone">
> link at the top of a message (my browser is configured to compose a Gmail
> message when I click a link like that).  The first thing I noticed was that
> even though that href link appears to ask your mail client to add an
> "In-Reply-To" header, Gmail does not actually recognize that request, and
> the Gmail message I sent to the list had no "In-Reply-To" header at all.
>  However... the archive view STILL threaded my reply correctly, even
> without that header!  So I went back to my "real list" and tried this same
> thing, and it did not in fact work on this list (using the web reply link).
>  So.. I do know now how to get my responses to thread properly on my real
> list (I must have received a real copy in my inbox and reply to it from
> there), but it is more of an academic curiosity why on some other list I
> found, the threading still works even in the complete absence of
> "In-Reply-To" headers.
> Thanks again.
> On the "test list" I was using

More information about the Mailman-Users mailing list