[Mailman-Users] Virtual Domains stopped working

Jan Steinman Jan at Bytesmiths.com
Fri Jun 22 02:58:49 CEST 2012

Environment: MacOS X 10.6.8 server on Mac Mini, Mailman v2.1.14, as supplied with MacOS X. I have a main MX mail server (mail.bytesmiths.com) and a number of other domain names, all sharing the same static IP. I run my own DNS, with all domains pointing MX records to mail.bytesmiths.com. Each of these domains have one or more mailman lists that were working properly a few days ago.

I added a new list to one of the domains (ecoreality.org) using the Mailman web interface. Then all my lists stopped working, with error messages like:
	<List_that_belongs_to_another_domain at bytesmiths.com>: user unknown

(I thought just the new one wasn't working, until someone forwarded me the reject notice they got when they tried to post to a list.)

/etc/postfix/main.cf refers to two mailman files:
	virtual_alias_maps = hash:/etc/postfix/virtual,hash:/var/mailman/data/virtual-mailman,hash:/etc/postfix/virtual_users
	alias_maps = hash:/etc/aliases,hash:/var/mailman/data/aliases

I went into /var/mailman/data and noticed that "aliases" was newer than "aliases.db". So in what was perhaps a foolish shot in the dark, I did "postmap aliases" and "postmap virtual-mailman" to refresh the .db files, but to no avail.

I can still get in the admin pages for the lists I administer, and I'm still getting subscription notifications via web sign-up, but sending out through at least several of the lists I've tried all fail.

Any clues what I can do to fix this? I'm fairly competent and happy to be pointed in the right direction.


You can't do anything about the length of your life, but you can do something about its width and depth. -- H. L. Mencken
:::: Jan Steinman, EcoReality Co-op ::::

More information about the Mailman-Users mailing list