[Mailman-Users] turn on tracing?

Mark Sapiro mark at msapiro.net
Fri May 20 11:54:47 EDT 2016

On 05/20/2016 05:35 AM, Richard Shetron wrote:
> How do I turn on tracing to find the source of this error.  The
> interface worked until I told check_perms to fix permissions so I'm sure
> there is a permission issue.  Also the qrunner won't run, which I also
> suspect is a permission error.  My partner who did the install has
> retired for medical reasons so I'm trying to learn how to do all sorts
> of things in too little time :(  I tried to look in both the mailman
> logs and the apache logs for errors and didn't find anything.
> Bug in Mailman version 2.1.21rc2
> We're sorry, we hit a bug!

There should be a traceback and other information about this error in
Mailman's error log. If it's not there, there is probably a permission
issue in writing the log.

You can at least temporarily ensure that Mailman's logs are writable by
anyone and see if that helps.

Also, you can edit $prefix/scripts/driver and at line 33 set


and the traceback will be included on the "we hit a bug" page.

Also, if check_perms -f broke things, permissions must have been set in
some non-standard way to begin with. See the FAQ article at

Mark Sapiro <mark at msapiro.net>        The highway is for gamblers,
San Francisco Bay Area, California    better use your sense - B. Dylan

More information about the Mailman-Users mailing list