[Matplotlib-devel] supported python versions

Thomas Caswell tcaswell at gmail.com
Sun Sep 27 21:49:36 CEST 2015

We already have this 'know to work with' vs 'supported' distinction, this
is the current state of python 3.2 support.  We don't test on it, my
response to 3.2 specific bugs is 'upgrade', but if we get reasonable,
non-destructive patches they will get merged (which we have done, around
the 1.4 release, after we dropped 3.2, we merged some patches
from Christoph Gohlke which fixed 3.2 on windows).

The reality is that we should have had this discussion 6-12 months ago
(sorry OceanWolf), instead of on the cusp of a release, and currently
master (and hence both the 1.5.0 and 2.0 releases) _will_ work with py2.6
and py3.3 because we are currently testing on them.  There is consensus in
the core developers that we will not support py2.6/3.3 going forward so the
question is what to do about the upcoming releases.  The options are:

 - do not document at all that as far as we know 1.5/2.0 will work on on
 - document that as far as we know mpl does work on py2.6, but are making
no commitment to make sure that stays true.

I very much like the second option as it is more accurate and gives _any_
support/hope to someone stuck on 2.6.

Danielle: If you are volunteering to maintain 1.5.x/2.0.x branches which
back ports bug fixes in a 2.6 compatibly that would be great, otherwise
given the limited resources the project currently has, that is not
something we can.

I have already linked to this article is this thread, but once more for
good measure:

For reference, debian stable no longer has 2.6 packaged (
https://wiki.debian.org/Python/JessieRoadmap) and RHEL has ways of getting
modern python running on older versions.

And again, as I have said at the bottom of every email, if there is someone
who really needs new features on 2.6, let me know and we will see if we can
work something out.


On Sun, Sep 27, 2015 at 12:31 PM OceanWolf <juichenieder-nabb at yahoo.co.uk>

> On 27/09/15 14:50, Daniele Nicolodi wrote:
> > I still don't understand what "know to work with" means. From the above
> > it seems that it means that "you may be luck and we have not break
> > compatibility, but if we did, then it is on you, we are not going to fix
> > it". With, to me, reads the same as "not supported".
> >
> > Breaking compatibility with python releases in patch version releases is
> > also a terrible idea, in my opinion.
> Yes, this underpins the reason for changing to "known to work with...",
> because we don't want to break compatibility in minor versions, but
> versions 1.5 and 2.0 have already been tested thoroughly on 2.6 and 3.3.
> > Matplotlib release 1.5 is release candidate now, and as far as I know it
> > is supposed to work with python 2.6. What changes are you foreseeing in
> > patch releases of the 1.5 series that will take advantage of breaking
> > compatibility with python 2.6?
> >
> > I believe that matplotlib 1.5 series will be only about bug fixing, and
> > that all development will go into 2.0. I don't really see how bug fixes
> > can be helped by dropping compatibility with old python releases.
> We release 2.0 shortly after 1.5 which means 1.5 won't have any patch
> fixes, and 2.0 contains no new features, but a change to the default
> colours.  But yes, dropping support for python 2.6 allows us use things
> such as OrderedDict, not saying we will use such things in 2.0.x
> (assuming we have a 2.0.x release, fingers crossed we find no bugs), but
> making the change now to the requirements keeps our options open for the
> future.
> Best,
> OceanWolf
> _______________________________________________
> Matplotlib-devel mailing list
> Matplotlib-devel at python.org
> https://mail.python.org/mailman/listinfo/matplotlib-devel
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.python.org/pipermail/matplotlib-devel/attachments/20150927/f83512f0/attachment-0001.html>

More information about the Matplotlib-devel mailing list