[Python-Dev] Re: PEP 279 revisited
Wed, 24 Apr 2002 22:23:17 +0200
On Wednesday 24 April 2002 18:13, David Abrahams wrote:
> > > should be named numer(), just like iter() is short for iterator. If
> Blick. Abbrevs suck. Plus I don't want to re-use the sucky name enum for
> something related to what 'C' and C++ use it for.
This proposal was for 'numer', not 'enum'. And, given a language that
has a 'def' keyword, and built-ins called 'dict', 'iter', 'vars', 'bool',
'str', 'repr', etc (:-), the affermation "abbrevs suck" looks pretty
peculiar to me. Note that a few of these are pretty new, too, so it's
not a question of "legacy" -- clearly the designer _prefers_ to use
abbreviations in certain places he deems suitable.