[Python-Dev] Berkeley breakage

Tim Peters tim at zope.com
Mon Aug 18 13:36:44 EDT 2003

[Skip Montanaro]
> I'm using it just fine with 3.3.11 on Mac OS X.  I'm not using
> pop3proxy though, just hammiefilter (for both scoring and incremental
> training) or hammie (for training from scratch).
> According to the pybsddb project's README.txt file (updated five
> weeks ago):
>     This wrapper should be compatible with BerkeleyDB releases going
> back to
>     3.1.17 up to and including DB 4.1.25.
> I'm not saying the poster is wrong, just that his problem is not
> trivially confirmed.

Berkeley version numbers seem partially insane, though:  if you have 3.3.11,
that doesn't tell us whether you've installed either, neither, or both of
the available Sleepycat patches *to* 3.3.11.  I don't know whether those
patches fix potential corruption problems in 3.3.11, but IIRC Sleepycat
patches don't bump the version number regardless.

More information about the Python-Dev mailing list