[Python-Dev] Addition of "pyprocessing" module to standard lib.

Bill Janssen janssen at parc.com
Mon May 19 19:02:36 CEST 2008

> Hmm, perhaps the ctypes documentation could use a more prominent warning 
> that it may not be available on some Unix platforms (HP-UX, AIX, IRIX), 
> and that it may require the use of GCC rather than the vendor compiler 
> on others (Solaris).
> At the moment, I suspect some projects may be switching to using it 
> without realising the implications for cross-platform portability.

I think it's a tad more problematic.  As other modules, both in and
out of the standard library, move to use ctypes, it implies that
*Python* isn't supported on those combinations.  Personally, that's
fine with me (as long as there's a workaround for Solaris!), but I
think that Ulrich is right in saying this should be more prominent.


More information about the Python-Dev mailing list