[Python-Dev] We now have C code coverage!

Terry Reedy tjreedy at udel.edu
Sat Jun 23 20:25:37 EDT 2018

On 6/23/2018 5:48 PM, Zachary Ware wrote:
> On Sat, Jun 23, 2018 at 2:20 PM, Terry Reedy <tjreedy at udel.edu> wrote:
>> Rechecking now, on Gentoo
>> test_idle appears and passed on these 3.6 and 3.7 pages
>> http://buildbot.python.org/all/#/builders/82/builds/414/steps/5/logs/stdio
>> Neither Firefox nor Edge can find 'test_idle' on these 3.x pages
>> http://buildbot.python.org/all/#/builders/103/builds/1149/steps/5/logs/stdio
>> http://buildbot.python.org/all/#/builders/99/builds/1130/steps/4/logs/stdio
>> test_tk appears on 1130 but not 1149
>> For your 8.1 bot: test_idle passed for 3.7
>> http://buildbot.python.org/all/#/builders/133/builds/339/steps/3/logs/stdio
>> but does is not found on this 3.x page (neither is 'test_tk')
>> http://buildbot.python.org/all/#/builders/12/builds/991/steps/3/logs/stdio
> Click the magnifying glass icon ("load all data for use with the
> browser search tool") at the upper right of the console pane and try
> again; each of the above is present and passed.  This does
> unfortunately seem to be another case of non-intuitive UI from
> buildbot.

Presenting data on the screen that cannot be found is terrible.  With 
Edge, I had to erase and retype the search word also.  With Firefox, 
that sometimes worked without pressing the magnifier.  I thought my copy 
of Firefox was broken until I tried Edge also.

>> Both Appveyor and my machine run test_idle when running the full 3.x test
>> suite.
> I am pleasantly surprised that AppVeyor does appear to be running the
> GUI tests :)

Terry Jan Reedy

More information about the Python-Dev mailing list