[Python-ideas] PEP 428: poll about the joining syntax
g.brandl at gmx.net
Thu Oct 11 00:45:33 CEST 2012
Am 10.10.2012 21:07, schrieb Antoine Pitrou:
> On Tue, 9 Oct 2012 00:45:41 +0530
> Nick Coghlan <ncoghlan at gmail.com> wrote:
>> On Tue, Oct 9, 2012 at 12:24 AM, Guido van Rossum <guido at python.org> wrote:
>> > I don't like any of those; I'd vote for another regular method, maybe
>> > p.pathjoin(q).
>> I don't *love* joinpath as a name, I just don't actively dislike it
>> the way I do the four presented options (and it has the virtue of the
>> path.py precedent).
> How about one_path.to(other_path) ?
I'd have no idea what it means, honestly.
More information about the Python-ideas