tummy compile Mandrake 7.2

myself twofingersalute at atl.mediaone.net
Sat Jun 9 16:41:35 CEST 2001


In article <mailman.992077754.21439.python-list at python.org>, "Sean
Reifschneider" <jafo at tummy.com> wrote:

>>line 246: Dependency tokens must begin with alpha-numeric, '_' or '/':
>>%defattr(-, r oot, root)
> 
> I'm not really sure what this is.  I'd appreciate it if somone could
> tell me -- it seems to be unique to Mandrake...  I don't reall get what
> it's trying to say, but have had the same report from another Mandrake
> user of getting the same error.
> 
>>BuildPrereq: expat-devel >= 1.1-3tummy BuildPrereq: db1-devel
>>BuildPrereq: gdbm-devel
>>
>>already have gdbm-devel, got and installed db1 and db1-devel, no clue as
>>to expat-devel as Mr. tummy doesn't seem to install it.
> 
> The stock RedHat expat RPM includes expat-devel.  If your expat RPM
> includes the devel files in the main package, try removing the
> BuildPrereq above.
> 
> Sean

thanks for your reply! well I guess I could have phrased the expat-devel
Q a little better- if devel is a build require, why isn't it included, or
offered as a separate srpm in ftp directory? Or are you saying I need the
"standard" expat pkgs in addition to the tummy ver? (but that's
confusing, as >=1.1-3tummy implies that there *is* a 1.1-3tummy devel
available)?? WRT line 246, surely someone here will be able to shed some
light for both our benefits- I haven't seen many problems go unsolved in
this ng (hint-hint). Actually I don't expect a necessarily specific
answer, just a clue where to look would suffice (hopefully).

OTOH, this gives me an opportunity to actually post here- this really is
an _excellent_ group!



More information about the Python-list mailing list