A counter-proposal to __future__ in PEP 236

William Tanksley wtanksle at dolphin.openprojects.net
Fri Mar 2 00:23:46 CET 2001

On Thu, 1 Mar 2001 15:45:17 -0500, Tim Peters wrote:

>from __future__ import nested_scopes
>assert nested_scopes[1] > sys.version_info, "don't need this anymore"

Is it really important that information such as this be stored as a tuple
rather than a dict (with symbolic names rather than numbers)?

assert nested_scopes.version_info > sys.version_info, \
                            "don't need this anymore"

I've always been taught that magic numbers are unpleasant.

-William "Billy" Tanksley

More information about the Python-list mailing list