[Pythonmac-SIG] pyObjC and Plugins

Dethe Elza delza at livingcode.org
Thu Mar 1 07:24:49 CET 2007

Hi Steve,

At some point py2app went from being bundled as part of PyObjC to  
being a separate install.  I think at that time there was a  
requirement to uninstall the old py2app before installing the new  
one.  I don't guarantee that is the solution to the problem you're  
having, but it's a possibility (your problem sounds very much like  
what I was facing, and this fixed it for me).  Instructions for  
uninstalling (and reinstalling) py2app are here:


Also, while it may help to remove older versions of and altgraph,  
bdist_mpkg, macholib, modulegraph, I'm pretty sure you don't have to  
install them explicitly.  They should come along as part of the  
py2app install, if I recall correctly.  The link above is to the  
py2app docs, so you should be able to find all the info there.

Good luck, and let us know how it goes!


On 28-Feb-07, at 10:11 PM, Steve Freitas wrote:

> Hi all,
> I've spent all evening unsuccessfully trying to get the  
> EnvironmentPrefs
> plugin working on my setup, and I hope you can help. I keep getting
> this:
> 2007-02-28 21:56:58.918 System Preferences[522] *** -[NSBundle load]:
> Error loading code /Users/steve/Library/PreferencePanes/Shell
> Environment.prefPane/Contents/MacOS/Shell Environment for
> bundle /Users/steve/Library/PreferencePanes/Shell  
> Environment.prefPane,
> error code 2 (link edit error code 0, error number 0 ())
> 2007-02-28 21:56:58.918 System Preferences[522] [NSPrefPaneBundle
> instantiatePrefPaneObject] (/Users/steve/Library/PreferencePanes/Shell
> Environment.prefPane): principalClass is nil.
> I found this earlier thread...
> http://mail.python.org/pipermail/pythonmac-sig//2006-October/ 
> 018298.html
> ...in which apparently upgrading to a later version of py2app fixed by
> Ronald Oussoren did the trick. However, doing the same hasn't fixed it
> for me, and I'm guessing in the flurry of reinstallations I left
> something out.
> I installed Python 2.5 from Python.org on a fresh install of 10.4.8. I
> installed, from source, pyObjC 1.4. I did easy_install [module] 
> ==dev for
> altgraph, bdist_mpkg, macholib, modulegraph and py2app.
>>>> print altgraph.__version__, bdist_mpkg.__version__, \
>     macholib.__version__, modulegraph.__version__, py2app.__version__
> 0.6.8 0.4.2 1.2 0.7.1 0.3.6
> Now, I did a lot of uninstallation and reinstallation of all of these
> pieces, and it's possible something from an old install is still  
> hanging
> around, since my uninstallation technique consisted of rm -Rf.  
> However,
> I'm not yet ready to try a fresh 10.4.8 installation again without
> someone telling me that's the only way.
> At various points in my console I also got the "ImportError: No module
> named linecache", but not on every attempt -- I'm not sure why. I've
> been careful to close and reopen System Preferences between each
> attempt, and I delete build/ and dist/ in the EnvironmentPrefs dir as
> well. If anyone could suggest something, I'd sure appreciate it.
> Thanks!
> Steve
> _______________________________________________
> Pythonmac-SIG maillist  -  Pythonmac-SIG at python.org
> http://mail.python.org/mailman/listinfo/pythonmac-sig

"Everyone has gotten so hung up on the legality of this they've  
forgotten the ethics." --Paul Saffo, on the H-P Scandal

More information about the Pythonmac-SIG mailing list