[Mailman-Users] Desperate plea for help ....

Pete Phillips pete at smtl.co.uk
Fri Mar 9 13:48:01 CET 2001

Firstly, thanks to you all for your prompt responses to my plea.

I've had some questions about our filesystem layout.  I've put a brief
description at the end of the message.

Progress so far regarding the various emails, with, perhaps the most
promising progress at the start from Travis:

>>>>> "Travis" == Travis Llewellyn <travisll at comfedcu.org> writes:
    Travis> Pete, What does you aliases file look like?

# Mailman mailing list manager
mailman: pete
mailman-owner: mailman

## mailmantest mailing list
test:                    "|/share/mailman/linux/mail/wrapper post test"
test-admin:              "|/share/mailman/linux/mail/wrapper mailowner test"
test-request:            "|/share/mailman/linux/mail/wrapper mailcmd test"
test-owner:              test-admin

    Travis> Also if you su to mail what happen when you run it
    Travis> manually?

Ah ha - if I su to mail and run 
   /share/mailman/linux/mail/wrapper mailcmd test

it doesn't complain !  It just sits there waiting for input. This is
who it thinks I am:

    #  su mail
    $ id
    uid=8(mail) gid=12(mail) groups=12(mail)

What does this mean ?  Have I misconfigured something (sounds like I
have) ?
>>>>> "Peter" == Peter Hutnick <peter-lists at hutnick.com> writes:
    Peter> Is wrapper setgid mailman?


-rwxr-sr-x   1 root     mailman     31163 Mar  1 12:59 /share/mailman/linux/mail/wrapper
>>>>> "Matt" == Matt Thoene <lists at thoene.net> writes:

    Matt> Pete, Have you tried doing a chmod -R 655 /mailman?  I was
    Matt> having similiar issues with no resolution and I read an
    Matt> archived post that suggested this.  It fixed my problem.

Tried this - I still get the same problem.

>>>>> "Christopher" == Christopher Kolar <ckolar at aurora.edu> writes:

    Christopher> I know that you said that you followed the install
    Christopher> docs, but just to make sure did you su - mailman
    Christopher> before running configure?  You cannot run ./configure
    Christopher> and ./make install as root.

Yes - I did all of this after su mailman.  
I just tried again with 2.0.2 - same error message.
>>>>> "Chris" == Chris Ryan <chris at greatbridge.com> writes:

    Chris> It's a shot in the dark but the only thing i can think of
    Chris> is it may be trying to run a different command? like maybe
    Chris> wrapper and mail-wrapper ??? Like I said it's a shot in the
    Chris> dark.

I'm sure it's trying the correct command - I installed mailman 2.0.2
10 minutes ago, and the mail logfiles show this:

Mar  9 10:57:25 ds9 Mailman mail-wrapper: Failure to exec script. WANTED gid 1, GOT gid 12.  (Reconfigure to take 12?) 
Mar  9 10:57:25 ds9 sendmail[11949]: f29AvOT11948: to="|/share/mailman/linux/mail/wrapper mailcmd test", ctladdr=<test-request at smtl.co.uk> (8/0), delay=00:00:00, xdelay=00:00:00, mailer=prog, pri=60853, dsn=5.3.0, stat=unknown mailer error 

ls -l /share/mailman/linux/mail/wrapper
-rwxr-sr-x   1 mailman  mailman     31163 Mar  9 10:47

So it looks as if the correct wrapper is being called.
>>>>> "Nick" == Nick Albright <nick.albright at v-space.org> writes:

    Nick>   Quick thougths, did you do a 'make clean' before
    Nick> reconfiguring?  Then do the 'configure' line below, and
    Nick> 'make' and 'make install'.  (I think those are the correct
    Nick> last 2 steps, I do know you need to make clean then do the
    Nick> configure for the changes to take effect)

Yep. I also cleaned everything out and started again with a clean
install, but no joy.
>>>>> "Steve" == Steve Pirk <Orion> writes:

    Steve> I replied to this once before I believe... Have you tried
    Steve> using "1" instead of "12"? I would mess around with various
    Steve> settings, trying it each time.

I did it with 

This is the wrapper now:
     -rwxr-sr-x   1 mailman  mailman     31163 Mar  9 11:26 linux/mail/wrapper

But I still get this message:

Mar  9 11:30:12 ds9 Mailman mail-wrapper: Failure to exec script. WANTED gid 1, GOT gid 12.  (Reconfigure to take 12?) 
Mar  9 11:30:12 ds9 sendmail[15822]: f29BUCT15821: to="|/share/mailman/linux/mail/wrapper mailcmd test", ctladdr=<test-request at smtl.co.uk> (8/0), delay=00:00:00, xdelay=00:00:00, mailer=prog, pri=60853, dsn=5.3.0, stat=unknown mailer error 2

    Steve> Make sure you "make install" as user mailman. I could be
    Steve> that some of the files cannot be exec'd properly because of
    Steve> permissions....

I did the configure, build and install as mailman.

>>>>> "Dan" == Dan Mick <Dan.Mick at west.sun.com> writes:

    Dan> And this means *EXACTLY* what it says.  The script wanted to
    Dan> be run with a GID of 1.  But it got 12.

    Dan> You must not be running the wrapper you think you're running.
    Dan> Perhaps the install step didn't actually work.

I know this isn't the case, as I stripped it all out, and checked that 
none of the files were on the system, then installed, ran check_perms
etc (about 2-3 times to get permissions OK), and now the files are


>>>>> "Teo" == Teo de Hesselle <teo.dehesselle at uts.edu.au> writes:

    Teo> sorry - you confused me. You should recompile with
    Teo> --with-mail-gid=12 

I've tried this - same message in mailog every time.

>>>>> "Steve" == Steve Lay <S.W.Lay at ucles-red.cam.ac.uk> writes:

    Steve> OK, seeing as your desperate ;-)

    Steve> I think you are probably looking for something more
    Steve> complicated than it is, here's my guess at what may be
    Steve> happening:

    >> ./configure --prefix=/share/store/mailman-2.0.1
    >> --exec-prefix=/share/store/mailman-2.0.1/linux
    >> --with-extra-inc=/share/links/include
    >> --with-extra-lib=/share/links/linux/lib --with-mail-gid='mail'
    >> --with-cgi-gid='nobody' --with-cgi-extension='.cgi'

    Steve> So the mail wrapper program is in
    Steve> /share/store/mailman-2.0.1/linux/mail/wrapper, right?

    >> However, if I run the following by hand:
    >> /share/mailman/linux/mail/wrapper mailcmd test2

/share/mailman is a link to /share/store/mailman-2.0.1, so the wraper
program can be accessed either direct as
*or* as

(Again, this is all related to the Eidelon file system we use).

    Steve> So what is in /share/mailman/linux?  Is this where you're
    Steve> building it from?

I build it in /share/store/mailman-2.0.1/src/mailman-2.0.1
It installs into /share/store/mailman-2.0.1
And then I do a  whole lot of linking stuff.

    >> Failure to exec script. WANTED gid 12, GOT gid 0.  (Reconfigure
    >> to take 0?)

    Steve> My guess is that you are fogetting to run "make install"
    Steve> after running ./configure.  In other words, the copy of the
    Steve> wrapper in the build directory works fine but the copy
    Steve> which is actually being used by your MTA is not.

Again, I have checked this out and it isn't the case - the stat
details on the file confirm that the correct file is being used.

    Steve> It's a bit of a
    Steve> long shot but at least this way you know that mailman-users
    Steve> is actually alive.

And don't think it's not appreciated - I have spent all morning trying 
out the various solutions you guys have kindly sent. Unfortunately
nothing so far has worked, but I'm optimistic about Travis' test,
running the wrapper after su to mail. Why does this not complain,
unlike everything else I've tried ?  Does this ring a bell with

Another thing that occurred to me was whether I had the fs mounted
correctly - but it seems OK:
 /dev/sda6               /share                  ext2    defaults        1 2

Finally, it appears I'm not the only one experiencing these problems - 
I had an email from another potential user this morning saying that he 
had exactly the same problem.

So, I have to go to a boring meeting for the rest if the day. Let's
hope someone can see the solution, and I'll have a go tonight or next

Thanks guys, and have a good w/e.

Brief note about the Eidelon file system layout.

Essentially we use the Eidelon file system standard. 

What this means is that we install the package in, for example,
/share/store/mailman-2.0.1/ then make a symbolic link from
/share/store/mailman-2.0.1/ to /share/mailman. We then run a script
that populates /share/links/linux/bin with links to
/share/mailman/linux/bin etc. This means that we can change versions
of a package just by changing the link which /share/mailman points to.

Until the Autumn, we were running Linux and SunOS workstations, and
this allowed us to keep 2 sets of binaries on the system without too
much trouble.

More information about the Mailman-Users mailing list