[Mailman-Users] How can I update 2.1.3 --> 2.1.5?

Brad Knowles brad.knowles at skynet.be
Tue Jun 1 19:16:40 CEST 2004

At 5:44 PM +0100 2004/06/01, Ian A B Eiloart wrote:

>  Now, one message said to check the UPDATES file. I have, but as far as
>  I can see, it doesn't actually say what to do to update. It does give
>  some advice about shutting down the MTA and the web site, and some other
>  tips about what to do *while* upgrading, but doesn't describe the basic
>  procedure.

	I'm confused.  The UPGRADING file says:


     For the most part, upgrading Mailman is as easy as just installing the
     latest version over the existing version.  However, there are some changes
     that need to be taken care of manually.

     What you need to do depends on the version you are using and the version
     you are upgrading to.  In all cases, you should first turn off your mail
     and web access to your Mailman installation.  You're essentially upgrading
     a database, and it's usually a good idea to make sure the database cannot
     be modified in the middle of the upgrade.

	What about this is not clear?  You turn off the MTA and the web 
server, and then you follow the instructions for installing the 
software.  That's about it.

	Hopefully, you will have kept all your changes in the mm_cfg.py 
file and not in the Defaults.py file, so that they will be carried 
over after the upgrade.

Brad Knowles, <brad.knowles at skynet.be>

"They that can give up essential liberty to obtain a little temporary
safety deserve neither liberty nor safety."
     -Benjamin Franklin, Historical Review of Pennsylvania.

   SAGE member since 1995.  See <http://www.sage.org/> for more info.

More information about the Mailman-Users mailing list