[Mailman-Users] More on news server errors

Richard Barrett r.barrett at openinfo.co.uk
Wed May 12 07:41:52 CEST 2004

On 12 May 2004, at 01:33, Con Wieland wrote:

> My problem is I get the following error:
> May 11 14:55:01 2004 (23921) error opening connection to nntp_host:
> (146, 'Connection refused')
> It looks like Mailman is trying to connect to  my newserver on port 
> 146 if I'm reading this right.

You are not. The 146 is just an error number whose description follows.

>  My *nix host is set to nntp on port 119. Port 119 does appear to work,

Mailman uses the default NNTP port number of 119 (but see below if you 
want it to use something else)

> I am able to make a connection to the news server when I telnet to it 
> on that port 119

But MM says it is getting connection refused when it tries.

> but  receive a similar looking error when I telnet port 146.
> directory.nac.uci.edu% telnet news.service.uci.edu 146
> Trying
> telnet: Unable to connect to remote host: Connection refused
> I have not been able to find any mailman configurations to change this.

In case you do want to explicitly specify a port number to use for NNTP 
then enter the NNTP host as 'host:port'

The code splits the host and port on the ':' in the string. If the ':' 
and port are absent it then it defaults to port 119.

> Any ideas?

MM is not using a non-standard port so you will probably have to look 
elsewhere for your solution.

> Con Wieland

More information about the Mailman-Users mailing list