[Mailman-Users] Mailman under Cygwin - won't add list

Mark Sapiro msapiro at value.net
Fri Dec 23 01:27:07 CET 2005

Ben wrote:

>> You need to run bin/newlist as mailman or some user in the 
>> Administrators group, not as Ben in group None.
>User 'Ben' and 'mailman' are both in the Administrators group.  It is
>cygwin that decides to display "None" as the file's group owner.  I
>assume this is just a limitation of Cygwin.

Maybe it is. The point is that in order for this to work, everything
must be in the same group that Apache is running as.

>On the Windows side (Manage: Users), I have users like this:
>	Ben, member of Administrators
>	mailman, member of Administrators
>In /etc/group, I have:
> Administrators:S-1-5-32-544:544:
>In /etc/passwd:
> Ben:unused_by_nt/2000/xp:1004:544:...
> mailman:unused_by_nt/2000/xp:1010:544:...
>So, as far as both Windows and Cygwin should be concerned, mailman _is_
>in the Administrators group.

But that clearly isn't what's happening. What do you get from

group Ben


group mailman

If they are in more than one group, I think files they create will be
assigned to the first group they belong to.

>Next, I tried running bin/netlist as mailman, as you suggest.  This
>gives the error:
>  File "/usr/local/mailman/Mailman/Site.py", line 40, in _makedir
>    os.makedirs(path, 02775)
>  File "/usr/lib/python2.4/os.py", line 159, in makedirs
>    mkdir(name, mode)
>OSError: [Errno 13] Permission denied:
>Next I tried 'chown -R mailman:Administrators /usr/local/mailman/lists'
>then tried again to add the list as 'mailman', which gives a different
>  File "/usr/local/mailman/Mailman/LockFile.py", line 422, in __write
>    fp = open(self.__tmpfname, 'w')
>IOError: [Errno 13] Permission denied:

So the locks/ directory doesn't have permission for user mailman and
whatever group it runs as. See below

>> or create the list via the web create interface.
>Tried that too.  I get an web page stating "Error: You are not
>authorized to create new mailing lists."

And what did you use for the password? It must be the site password or
the list creator password set by bin/mmsitepass. If you used one of
these, and it didn't work then it's probably permissions on
data/adm.pw or data/creator.pw.

>> > As before, it is the 660 permission bits, not the 
>> > owner/group, which is causing Mailman to choke.
>> > I can't understand why Mailman's 'newlist' 
>> > uses this permission mask to create files which Mailman
>> > will subsequently refuse to read.
>> Because it expects to be run as the mailman user.
>But, it won't be run as the 'mailman' user when it's invoked from
>Apache, so that assumption will surely fail, right?

Well, actually it expects to be run in the mailman group which in your
case is the Administrators group. Any files it creates have to be
group owned by Administrators.

>> The underlying problem here is Windows lack of support for 
>> setting effective user and group ids. This breaks all kinds 
>> of things that Mailman assumes about its environment.
>Yes, that's clear :)  The question remaining is, is there any hope of
>getting around it :(

Well, in my case, everything runs as user Mark and group None so
everything is in the None group, and it works. In your case at least
Apache is running as a service presumably in the Administrators group
so everything has to be in the Administrators group for things to work.


cd to the 'prefix' directory, and

chgrp -R Administrators .

or maybe better

chown -R mailman:Administrators .

Then the web stuff should work.

BTW, did you run bin/check_perms after reconfiguring with

Mark Sapiro <msapiro at value.net>       The highway is for gamblers,
San Francisco Bay Area, California    better use your sense - B. Dylan

More information about the Mailman-Users mailing list