[Mailman-Users] mailmanlistinfo without slash

John Fleming john at wa9als.com
Fri Jan 28 13:47:16 CET 2005

----- Original Message ----- 
From: "Mark Sapiro" <msapiro at value.net>
To: "John Fleming" <john at wa9als.com>; <mailman-users at python.org>
Sent: Thursday, January 27, 2005 11:08 PM
Subject: Re: [Mailman-Users] mailmanlistinfo without slash

> John Fleming wrote:
>>Well, it doesn't like bin/arch as above because the archive is empty:
>>Luke:/var/lib/mailman/bin# ./arch --wipe sked
>>Cannot open mbox file 
>>[Errno 2] No such file or directory:
>>I also tried just ./arch without the --wipe and got the same error.
>>*** I did create a brand new test list, and the link is CORRECT for that
>>list, so fix_url after adding the trailing slash did fix the problem.  Now
>>to get the existing lists fixed - maybe.  I intend for these lists to NOT
>>have archives, so it's academic for existing lists.  I just would like fix
>>it so that the incorrect link doesn't appear if someone goes there out of
>>curiosity and then hits the listinfo link to get back.  I guess I might 
>>to save the config and recreate the lists if I really want the link fixed
>>that badly.  Thanks Mark and Tokio for your help - Future lists won't have
>>this problem!  - John
> Tokio's suggestion to move (or copy) lists/<listname>/config.pck aside
> and then remove and recreate the list and then move the config.pck
> back is a good one, but a simpler idea is if there is no
> archives/private/<listname>.mbox/<listname>.mbox file, just do
> bin/arch --wipe sked /dev/null
> or whatever your other list names might be.
> I tested that this time and it works :-)

The above seemed to work.  I restarted Mailman, and then when clicking the 
Archives link on the Listinfo page, I was taken to
You don't have permission to access /pipermail/sked/ on this server.

I thought maybe I just needed to rebuild the archive, so I did that, but 
same error.  I looked at the permissions of 
/var/lib/mailman/archives/private/sked.mbox and it is the same as my other 
lists that don't give the FORBIDDEN error - group-list, owner www-data, 2775 
(set GID).  Which page exactly has incorrect permissions?

Here's the bin/arch run:

Luke:/var/lib/mailman/bin# ./arch --wipe sked /dev/null
Traceback (most recent call last):
  File "./arch", line 187, in ?
  File "./arch", line 166, in main
  File "/usr/lib/python2.3/shutil.py", line 142, in rmtree
    raise exc[0], (exc[1][0], exc[1][1] + ' removing '+arg)
OSError: [Errno 2] No such file or directory removing 

No virus found in this outgoing message.
Checked by AVG Anti-Virus.
Version: 7.0.300 / Virus Database: 265.8.1 - Release Date: 1/27/2005

More information about the Mailman-Users mailing list