[Mailman-Users] Not getting aliases, owner notification on newlist

Mark Sapiro msapiro at value.net
Tue Mar 27 17:45:41 CEST 2007

Jock Coats wrote:
>I've been using Mailman 2.1.6 for some time now that I happily  
>compiled and installed from source on my own server.  Now I've needed  
>to move to another server and at first I took the opportunity to  
>upgrade to 2.1.9.  But the OutgoingRunner NEVER worked - logging is  
>not very verbose for all of this but when I tried running it manually  
>- qrunner -v -r Outgoing I got "segmentation fault".

I'd go back to 2.1.9 because you have the same problem with the Debian

>I then deleted and recreated the site-list and still got the same  
>I notice in the logs/error I seem to get:
>Mar 27 08:19:14 2007 (22935) Master qrunner detected subprocess exit
>(pid: 26312, sig: 11, sts: None, class: OutgoingRunner, slice: 1/1)  
>Mar 27 08:19:14 2007 (26757) OutgoingRunner qrunner started.

This looks like it's from the qrunner log, not the error log, but it
says OutgoingRunner was killed with signal 11 - SIGSEGV segmentation

>Every time it tries to send a message - that one coincided with me  
>deleting and recreating the site list.
>Can I get more verbose output than that?

Since your outgoing runner dies in the same way with both versions,
perhaps this is a Python problem, not a mailman problem.

for some debugging techniques.

>There's nothing left over in the qfiles directories, though both in  
>and out are shown as modified at the same time as that OutgoingRunner  
>error above.

With 2.1.9, there will be a .bak file left in the 'out' queue, but it
will be reprocessed when outgoing runner restarts which will repeat
the failure in a loop until the retry limit for qrunners is reached.

>I watch my postfix logs while I am doing all this and see absolutely  
>nothing.  If I try to send a message either to the site list, or to  
>mailman-owner, it shows up in the postfix logs passing it onto the  
>post command and deleting it from the postfix queues after which it  
>just seems to get lost, neither coming back out to the 'real' mailman- 
>owner nor getting syphoned off in shunt or anything like that - just  
>quietly dying.

Because Mailman is unable to send any outgoing mail. It tries,
OutgoingRunner is killed because of the segmentation violation and the
out queue entry is lost.

Mark Sapiro <msapiro at value.net>       The highway is for gamblers,
San Francisco Bay Area, California    better use your sense - B. Dylan

More information about the Mailman-Users mailing list