[Mailman-Users] Not getting aliases, owner notification on newlist

Jock Coats jock.coats at jcsolutions.co.uk
Tue Mar 27 21:47:07 CEST 2007

On 27 Mar 2007, at 16:45, Mark Sapiro wrote:

> I'd go back to 2.1.9 because you have the same problem with the Debian
> package.

Okay - I've done that.  In fact I also installed Python 2.5 from  
source rather than relying on Sarge's 2.4 port just in case it was that.

I appear to have similar problems but...

> Since your outgoing runner dies in the same way with both versions,
> perhaps this is a Python problem, not a mailman problem.

I do not suspect Python any more, but Postfix itself.,,

> See
> <http://www.python.org/cgi-bin/faqw-mm.py?req=show&file=faq04.073.htp>
> for some debugging techniques.

Hacking the SMTPDirect.py handler to increase the debugging  
information produced the following lines in logs/error (for sure this  
time - you were right it was logs/qrunner last time I quoted!):

Mar 27 20:04:00 2007 qrunner(21277): connect:   ('localhost', 25)

...ten times for each attempt to deliver anything, then the  
OutgoingRunner process is terminated.  But when I deleted anything in  
qfiles (there was the "virgin" message from setting up the site list  
sitting there I think it was) and tried bin/qrunner -v -r Outgoing it  
workd and just sat there in foreground apparently.  Until, in another  
shell, I removed and recreated the site list prompting it to try to  
send an outgoing message to the listowner.  As soon as I bin/ 
mailmanctle start - ed after that Outgoing once again collapses with  
those same messages in logs/error.

So, I tried telneting to port 25 on localhost and it drops the  
connection immediately.  I tried telneting to hostname port 25 and it  
worked.  So I've got postfix for some reason that I cannot fathom  
dropping connections from localhost to localhost.  Postfix logs  
"warning: process /usr/lib/postfix/smtpd pid 21392 killed by signal  
11" at this point so I think the answer is not in this forum, but  
something to do with postfix.  I guess I could maybe change the  
outbound mailhost somewhere in Mailman's config could I to see if  
that gets round it for now?

Thanks again,


Jock Coats
Warden's Flat 1e, J Block Morrell Hall, OXFORD, OX3 0FF
w: +44 (0)1865 483353 h: +44 (0)1865 485019
m: +44 (0)7769 695767 e: jock.coats at jcsolutions.co.uk
www: http://jockcoats.blogspot.com/

More information about the Mailman-Users mailing list