[Mailman-Users] Not getting aliases, owner notification on newlist

Brad Knowles brad at shub-internet.org
Wed Mar 28 05:12:33 CEST 2007

At 8:47 PM +0100 3/27/07, Jock Coats wrote:

>  Okay - I've done that.  In fact I also installed Python 2.5 from
>  source rather than relying on Sarge's 2.4 port just in case it was that.

No, you really want Python 2.4.4, not 2.3.anything or 2.5.anything. 
The problem is that 2.3.anything is to old (and breaks things in the 
Mailman code), and 2.5.anything is too new (and breaks things in the 
Mailman code).

Trust me, you really want the latest release from the 2.4 tree, for 
use with Mailman 2.1.9.

>  So, I tried telneting to port 25 on localhost and it drops the
>  connection immediately.  I tried telneting to hostname port 25 and it
>  worked.  So I've got postfix for some reason that I cannot fathom
>  dropping connections from localhost to localhost.

There's the problem.  Postfix probably isn't configured to listen on 
the localhost IP address.  Try adding that to the list of interfaces 
for postfix to listen on.

>                                 I guess I could maybe change the
>  outbound mailhost somewhere in Mailman's config could I to see if
>  that gets round it for now?

That could also work.

Brad Knowles <brad at shub-internet.org>, Consultant & Author
LinkedIn Profile: <http://tinyurl.com/y8kpxu>
Slides from Invited Talks: <http://tinyurl.com/tj6q4>

More information about the Mailman-Users mailing list