[Mailman-Users] Attachments and blank messages

Sciamano sciamano72 at gmail.com
Sat Apr 12 17:15:37 CEST 2008

On 4/12/08, Mark Sapiro <mark at msapiro.net> wrote:

> This seems like a problem with the MUAs (mail clients) reading the
>  message rather than the message.

That might be the issue, since I can read the messages correctly using KMail.

> Set your content filtering as follows to do what you say you want.


>  convert_html_to_plaintext doesn't matter because no HTML will get there

But won't this affect the Excite user?

>  The above will remove everything which is not a text/plain part from
>  the delivered messages.

That's what I'm worried about, considering the fact that Excite
appends HTML automatically to outgoing messages. Won't this make all
messages from the Excite user be rejected?

>  If you want to allow HTML that isn't in a multipart/alternative part
>  and convert it to plain text with lynx or whatever is set in mm_cfg.py
>  as HTML_TO_PLAIN_TEXT_COMMAND, then add text/html to pass_mime_types
>  and set convert_html_to_plaintext to Yes.

I don't know how to do this. I have access to Mailman through a cPanel
hosting account, I have no direct access to the server and its
configuration files.

>  If the above suggestions do not resolve the problem, we need to see a
>  sample of each message (one 'office' and one 'excite'). The samples
>  can be edited for privacy, but they need to be raw messages as sent by
>  the user (not necessarily to the list) with the MIME structure and
>  headers intact. I.e., they need to be messages as sent by the users,
>  not as delivered by the list.

Ok, I've set up the list as per your suggestions.
I will keep you posted whether the problems have been solved this way.
If not, I'll try to forward the original messages.
Thanks for your help so far.


More information about the Mailman-Users mailing list