[Mailman-Users] Lists created via web admin seem to be entirelyseparate from lists created from command line

Mark Sapiro mark at msapiro.net
Tue Mar 13 06:37:09 CET 2012

Mark Leone wrote:

>I just installed Mailman 2.1.14 and got it integrated with Postfix, on
>Ubuntu 11.04. I can create a list via the web admin interface, and add
>members to it. But no such list exists if I run bin/list_lists. If I run
>bin/newlist without creating a list via the web admin interface, I can send
>mail to the list, but when I try to administer it via the web interface, it
>doesn't exist. If I then create the list at the web interface, there is no
>connection between the web instance and the instance reachable via e-mail.
>That is, I add a member via the web interface, but when I send mail from
>that address, it's sent to the list moderator for vetting because it
>supposedly came from a non-member. And in similar fashion I get an e-mail at
>the list-admin address, telling me that I have a post to disposition. But
>when I click on the link in the e-mail, the Mailman web app says there are
>no pending requests.

All of this says that your web server does not point to the same
mailman instance that Postfix points to and that you are accessing
from the command line.

Check the path in your Mailman ScriptAlias in your web server config.

Mark Sapiro <mark at msapiro.net>        The highway is for gamblers,
San Francisco Bay Area, California    better use your sense - B. Dylan

More information about the Mailman-Users mailing list